Faire passer Mozilla pour IE

Vous cherchez une solution complète et libre ? La curiosité vous presse de poser des questions sur SeaMonkey (successeur de la suite Mozilla), et vous ne parvenez pas à trouver de réponses ? Venez ici, et trouvez votre bonheur.

Modérateur : Mori

Répondre
Starcom
Salamandre
Messages : 20
Enregistré le : 10 sept. 2003, 10:21

Faire passer Mozilla pour IE

Message par Starcom » 10 sept. 2003, 10:29

Bonjour,

Un nouveau firewall a été installé sur mon lieu de travail et ne laisse passer que les navigateurs identifiés comme étant IE (je sais, c'est pas malin, mais bon ;) ).

Du coup, j'peux plus me servir de Moz. Par contre Opera et Crazy Browser, aucun problème.

Y a-t-il une manip' que je pourrais faire pour que Moz se fasse passer pour IE ?

olab
Varan
Messages : 1254
Enregistré le : 30 juil. 2003, 20:20
Localisation : Niort
Contact :

Message par olab » 10 sept. 2003, 10:37

Bjour,

essaye avec l'un des extensions qui suivent, elles te permettent de changer l'identification de ton navigateur (ça marche pas à tout les coup mais pour ton proxy, ça devrait passer)

http://texturizer.net/firebird/extensio ... 20Switcher

http://texturizer.net/firebird/extensio ... r%20Widget

O

Jigho
Iguane
Messages : 637
Enregistré le : 29 juil. 2003, 08:44
Localisation : Paris

Message par Jigho » 10 sept. 2003, 10:37

L'astuce est de changer la chaine "user-agent" qui identifie le navigateur.
Essaie de voir là :
http://texturizer.net/firebird/extensio ... r%20Widget

Je sais que certaines extensions posaient problemes avec java en particulier, mais je ne sais pas si c'est résolu

Edit : damned, trop lent !
Image

Starcom
Salamandre
Messages : 20
Enregistré le : 10 sept. 2003, 10:21

Message par Starcom » 10 sept. 2003, 11:47

Merci pour vos réponses.

Apparament ça ne résoud pas mon problème. Peut-être que le problème de connexion ne vient pas de là...

En tout cas merci. Vous avez répondu rapidement et correctement.

olab
Varan
Messages : 1254
Enregistré le : 30 juil. 2003, 20:20
Localisation : Niort
Contact :

Message par olab » 10 sept. 2003, 12:04

Jigho a écrit :Edit : damned, trop lent !
Bisque bisque rage... :P
Prem's

Lemm
Arias
Messages : 18
Enregistré le : 28 juil. 2003, 16:05

Message par Lemm » 10 sept. 2003, 14:46

Je ne suis pas du tout sur que ces extensions soient compatibles avec Mozilla (mais je me trompe peut être) Je connais une extension qui permet de changer le User-Agent de Mozilla, c'est Prefbar. Celle-là je suis certain qu'elle fonctionne, tu peux toujours essayer ;-)

Jigho
Iguane
Messages : 637
Enregistré le : 29 juil. 2003, 08:44
Localisation : Paris

Message par Jigho » 10 sept. 2003, 14:50

Lemm a écrit :Je ne suis pas du tout sur que ces extensions soient compatibles avec Mozilla (mais je me trompe peut être)
Pas faux, c'est effectivement pour Fb.... honte à moi (enfin, à nous, même...)
Grrrr, c'est beau d'avoir 2 codes que les jeunes ils comprennent pas la différence, mais quand les vieux se mélangent aussi... :evil:

Ajout :

Pour info, au détour d'un butinage, j'ai noté qu'il vaut mieux faire attention à remettre le "user agent" sur sa valeur par défaut (mozilla...) avant de désinstaller prefbar (le cas échéant). Sinon, ça peut poser des problemes, puisque le navigateur reste identifié avec une fausse valeur (ex. problemes avec java, semble-t-il)

De toutes façons, il faut toujours laisser mozilla être mozilla, ne serait-ce que pour les statistiques que font de nombreux admins de sites, et ne basculer sur un faux "ie" que quand c'est vraiment nécessaire...
Image

olab
Varan
Messages : 1254
Enregistré le : 30 juil. 2003, 20:20
Localisation : Niort
Contact :

Message par olab » 10 sept. 2003, 15:11

Jigho a écrit : Pas faux, c'est effectivement pour Fb.... honte à moi (enfin, à nous, même...)
Pas si sûr parce que http://texturizer.net/firebird/extensio ... r%20Widget c'est l'ancien uabar, qui se trouve sur Mozdev et je me souviens l'avoir installé sur mozilla. L'autre aussi d'ailleurs mais j'en suis moins sûr.

O

Starcom
Salamandre
Messages : 20
Enregistré le : 10 sept. 2003, 10:21

Message par Starcom » 11 sept. 2003, 09:17

Lemm a écrit :Je ne suis pas du tout sur que ces extensions soient compatibles avec Mozilla (mais je me trompe peut être)
Non, tu ne te trompes pas, ces extensions ne s'étaient pas installées sous Mozilla 1.3.1 Fr. J'ai dû télécharger Firebird pour les essayer mais je passe pas le firewall avec :(.

Merci pour l'extension que tu m'as indiqué. Je l'ai essayé et idem: Je passe pas le firewall. Franchement je me demande ce qui peut m'empêcher de traverser avec Mozilla et Firebird si c'est pas le User-Agent ?

Jigho
Iguane
Messages : 637
Enregistré le : 29 juil. 2003, 08:44
Localisation : Paris

Message par Jigho » 11 sept. 2003, 09:19

Starcom a écrit :Franchement je me demande ce qui peut m'empêcher de traverser avec Mozilla et Firebird si c'est pas le User-Agent ?
Tu as bien réglé les paramètres du proxy comme dans IE ?
Image

Invité

Message par Invité » 11 sept. 2003, 10:55

Jigho a écrit : Tu as bien réglé les paramètres du proxy comme dans IE ?
Normalement j'ai pas à le faire, c'est configuré dans la base de registre. Dans le navigateur, j'ai juste à mettre connexion directe.

olab
Varan
Messages : 1254
Enregistré le : 30 juil. 2003, 20:20
Localisation : Niort
Contact :

Message par olab » 11 sept. 2003, 10:59

Ok ça doit pas être dans la base de registre mais plutôt c'est une passerelle qui est paramétrée. Dans IE dans la partie connexions>Paramètres réseau, qu'est-ce qu'il y a d'activé ?

Starcom
Salamandre
Messages : 20
Enregistré le : 10 sept. 2003, 10:21

Message par Starcom » 11 sept. 2003, 11:16

Bin j'ai les deux cases du cadre "serveur proxy" activées plus le nom du proxy et son port.
C'est vrai que si je décoche ça IE marche plus.
Mais dans Mozilla si je veux mettre manuellement le même proxy, il faut que je choisisse socks4 ou 5 et la le proxy/firewall de ma boite me jette avec ce message:

ERREUR
Accès au cache interdit

En essayant de charger l'URL : http://geckozone.tuxfamily.org/geckoforum/index.php

L'erreur suivante a été rencontrée :

* Accès au cache interdit.

Désolé, vous n'êtes actuellement pas autorisé à demander

http://geckozone.tuxfamily.org/geckoforum/index.php

à ce cache tant que vous ne vous êtes pas identifié.

Vous avez besoin de Netscape version 2.0 ou supérieure, ou Microsoft Internet Explorer 3.0, ou un navigateur conforme à HTTP/1.1 pour que ceci fonctionne. Veuillez contacter l'administrateur du cache si vous avez des difficultés à vous authentifier, ou changez votre mot de passe.

Generated Thu, 11 Sep 2003 09:13:40 GMT by lenomduproxydemaboîte.fr (Squid/2.5-ntlm)

olab
Varan
Messages : 1254
Enregistré le : 30 juil. 2003, 20:20
Localisation : Niort
Contact :

Message par olab » 11 sept. 2003, 11:37

Starcom a écrit : Generated Thu, 11 Sep 2003 09:13:40 GMT by lenomduproxydemaboîte.fr (Squid/2.5-ntlm)
Tu as bien fait de mettre tout le message, le problème est là : ntlm. Il s'agit d'une identification particulière. Il me semblait pourtant que Mozilla gérait ça maintenant. Tu as la 1.4 ou la 1.3.1 (comme dit avant) ? La 1.4 doit gérer l'authentification NTLM :

http://mozilla.org/releases/mozilla1.4/README.html#new
Mozilla on Windows now has support for NTLM authentication. This enables Mozilla to talk to MS web and proxy servers that are configured to use "windows integrated security".

Starcom
Salamandre
Messages : 20
Enregistré le : 10 sept. 2003, 10:21

Message par Starcom » 11 sept. 2003, 15:47

Impec !

J'ai télécharger la 1.4 et j'ai saisi mon nom d'utilisateur NT et mon mot de passe réseau et voilà.

Ca marche nickel !!

Un grand merci à toi olab, chapeau bas !! :D

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité