changement d'utilisateur, récupération de l'essentiel, e F

Vous cherchez une solution complète et libre ? La curiosité vous presse de poser des questions sur SeaMonkey (successeur de la suite Mozilla), et vous ne parvenez pas à trouver de réponses ? Venez ici, et trouvez votre bonheur.

Modérateur : Mori

Répondre
Invité

changement d'utilisateur, récupération de l'essentiel, e F

Message par Invité » 23 janv. 2004, 12:38

Vu le nombre de posts, concernant la récupération de données (mails, carnet d'adresse,etc...) , et les passerelles d'utilisateur à utilisateur qui semblent totalement absentes, ce serait bien que la FAQ aborde ces problèmes !!!

C'est d'autant plus inquiétant que tous les posts que j'ai lu sur le sujet semblent rester sans réponse : la personne qui a posté semble rester avec un problème non résolu (ce qui est mon cas pour l'instant)....

D'autant plus étonnant qu'à part ce pb de récupération de données, mozilla semble être un bon logiciel .... :?: :?: :?:

cslevine
Arias
Messages : 4
Enregistré le : 22 janv. 2004, 14:16

Bien vu

Message par cslevine » 23 janv. 2004, 14:02

Bien d'accord avec toi donc. et je vois que d'autres sont d'accord avec moi.

un BON logiciel est avant tout un logiciel FIABLE.

Or Mozilla étant aussi peu fiable que Outlook, au niveau des données, et bien... j'ai vu : idem pour les "pièces détachées" qui ont un autre nom. Même philosophie !

On vit vraiment une époque de régression au niveau intellectuel et conception des choses, aujourd'hui. Et ce qui est le pire dans tout ca, c'est que de grands prophètes ont prédit exactement celà pour exactement notre époque. Ca fout les boules...

Invité

Message par Invité » 23 janv. 2004, 14:23

En fait, lorsque j'étais sous OE, le changement de directory se faisait en un ou 2 clics, et je n'avais aucun souci.

Cela étant, je me suis aussi retrouvé avec un spamming épouvantable, et vu la qualité des produits Bilou, question sécurité, je crois que cela venait de ce gruyère d'OE.

En plus, j'ai pris Mozilla, car il y a un outil de filtrage du spamming qui est réellement super, et je n'ai plus du tout de spamming.

Donc, en fait, je tire pas trop à boulets rouges sur Mozilla, je pense que c'est un très bon logiciel, sauf ce pb de changement de profil, ou même d'emplacement d'archivage de mails, qui est réellement CAUCHEMARDESQUE.

J'ai perdu un ou 2 mails dans la bataille, mais je crois avoir ENFIN une solution :

1) tu as tous tes mails, archivés en D:\sauvegarde

2) tu crées un profil, ensuite tu recrées tes comptes, un par un.
Pour chaque compte, tu copies les fichiers inBox, sent, etc....
(faire gaffe à ne pas être connecté, car sinon, tu risques de perdre ce qui va rentrer, pendant cette manip)

Il faut bien avoir repéré le compte pop de la sauvegarde (popXX), pour le transférer dans le nouveau popYY (c'est vraiment n'importe quoi, ce défaut à l'export)


J'ai récupéré tous les Inbox.
Pour les Sent et Drafts, j'ai pas, mais c'est moins grave.

Pour le carnet d'adresse, c'est dans la FAQ : fichier abook.mab.

Voilà.
3) si tu sautes l'étape 2), tu as tes comptes, mais vides : pas de Inbox, que dale ....,

:roll:
:roll: :roll: :roll:

SergeB
Arias
Messages : 7
Enregistré le : 20 juil. 2003, 23:32

Message par SergeB » 08 févr. 2004, 14:58

Hum je suis pas sûr d'avoir bien compris ton problème, mais si c'est ce que je pense, j'ai une solution bien plus simple.

En fait, tu peux sans problème sauvegarder tout le dossier profil (éventuellement en supprimant les dossiers /chrome et /Cache, ainsi que xul.mfl et d'autres crasses). Il suffit alors de le remettre dans les dossiers personnels avant de réinstaller Mozilla.
Le problème des comptes qui apparaissent mais sans aucun dossier à l'intérieur vient du fait que le chemin d'accès aux dossiers des mails n'est pas relatif (au répertoire du profil par ex) mais bien absolu. Ainsi, si ton profil se trouve dans C:\Documents and settings\[Utlisitateur]\Application data\Mozilla\profiles\[...]\default\, le répertoire des mails n'est pas défini comme "\Mail", mais bien "C:\Documents and settings\[Utlisitateur]\Application data\Mozilla\profiles\[...]\default\Mail". Donc, il suffit que tu aies changé de répertoire pour le profil (par exemple autre nom d'utilisateur Windows) ou que les chiffres cabalistiques du profil ([...] dans mon exemple) aient changé (nouvelle génération de profil) pour qu'il ne retrouve plus les dossiers des comptes. Il faut alors aller dans "Paramètres des comptes", et pour chaque compte modifier le "Dossier local" dans "Paramètres serveurs".

En espérant que ça puisse aider...

P.S. cslevine tu trouves pas que t'en fais un peu trop là ? C'est pas parce qu'un logiciel n'est pas parfait qu'on assiste à une régression intellectuelle... Au contraire puisqu'il est en constante amélioration. En outre, je vois pas ce qu'il y avait de mieux avant qui justifie une idée de "régression"... Par contre, faire référence à des prophéties obscurantistes à la Nostradamus, ça je trouve que c'est régresser... :roll:

baquet

Message par baquet » 10 févr. 2004, 10:07

SergeB a écrit : Il faut alors aller dans "Paramètres des comptes", et pour chaque compte modifier le "Dossier local" dans "Paramètres serveurs".
J'ai fait comme ça, et je me croyais sauvé.
Hélas, le CAUCHEMARD continue : j'ai créé un nouveau compte, et, par défaut, celà crée un nouveau dossier à l'ancienne adresse, sur l'ancien disque, où l'ancienne arborescence, avec l'ancien path, est recréée.
Constatant qu'un cache y est aussi généré, je suis retourné voir ce qu'il y a à présent dans les prefs.
les 4 lignes suivantes pointent toujours sur l'ancienne adresse :
user_pref("browser.cache.disk.parent_directory", E:\\_Mozxxx
user_pref("mail.root.none", "E:\\_Mozxxx
user_pref("mail.root.pop3", "E:\\_Mozxxx
user_pref("mail.server.server6.directory", "E:\\_Mozxxx

(alors que le profil est à présent sur D et non sur E)

Sachant que (dans un test de migration précédent) lorsque j'avais fait un replace massif des chemins dans ce fichier, tous les .msf avaient du être recalculés un par un en cliquant sur mes 187 dossiers, j'hésite à refaire la manoeuvre.

1) Quelqu'un sait-il comment s'y prendre ?
2) Quel N° de bug lire sur bugzilla pour suivre la progression des développements sur ces questions ?

SergeB
Arias
Messages : 7
Enregistré le : 20 juil. 2003, 23:32

Message par SergeB » 10 févr. 2004, 22:41

J'ai l'impression que tu te compliques la vie, enfin voici ce que je te conseille.

Après avoir tout désinstallé, et _avant_ de réinstaller, il faut placer ton ancien profil au complet à la place où il devra être. Pas nécessaire de créer un nouveau profil à partir de la nouvelle version que tu as installée. Normalement il devrait détacter que tu as déjà un profil sur cet ordinateur et utiliser ce profil.

Ce que je ne comprends pas du tout, c'est la syntaxe "E:\\_Mozxxx"... ça ne correspond à rien de normal à ma connaissance : pas de double slash après une adresse de disque, pas d'underscore avant le dossier, et je ne comprends pas l'intérêt de mettre le dossier à la racine du disque...

Enfin, j'ai du mal à comprendre toute la situation.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités