Son joué à l'arrivée de nouveaux mails

Vous cherchez une solution complète et libre ? La curiosité vous presse de poser des questions sur SeaMonkey (successeur de la suite Mozilla), et vous ne parvenez pas à trouver de réponses ? Venez ici, et trouvez votre bonheur.

Modérateur : Mori

Répondre
Tonio
Arias
Messages : 4
Enregistré le : 29 juil. 2003, 13:34

Son joué à l'arrivée de nouveaux mails

Message par Tonio » 28 nov. 2003, 12:21

Bonjour,

Le client mail de Mozilla offre la possibilité de jouer un son à l'arrivée de nouveaux mails. J'ai donc saisie cette opportunité et utilise un fichier wav de 2,3 secondes.

Le hic c'est que lorsque Mozilla joue le son (via je ne sais quel programme externe), l'application frizze totalement le temps du son et il est impossible de cliquer ou que ce soit ou de saisir du texte.

Bien sûr la saisie ou les clicks effectués dans le logiciel ne sont pas perdus, tout reprend sa place dès que le son est terminé.

Ce n'est pas un gros problème mais c'est un peu gênant lorsqu'on travaille sous Mozilla de devoir attendre quelques secondes à chaque fois. La solution serait donc que je vire ce son, mais je me demandais juste si il n'y avait pas un truc à faire pour pouvoir conserver cette fonctionnalité sans cet inconvénient.

Merci d'avance pour votre aide,

a+
Tonio (knoppix 3.3, moz 1.5)

olab
Varan
Messages : 1254
Enregistré le : 30 juil. 2003, 20:20
Localisation : Niort
Contact :

Message par olab » 28 nov. 2003, 15:05

Il me semble que lorsqu'on programme la lecture d'un son (je veux dire dans le code surce d'un programme), on a le choix entre une lecture synchronisée et une désynchronisée. La deuxième permet de continue à travailler, la deuxième fait que le son est joué et ensuite on reprend la main, ton cas donc. Peut être que le code est tel que, peut être en allant surfer dans le code tu sauras :-)

Tonio
Arias
Messages : 4
Enregistré le : 29 juil. 2003, 13:34

Message par Tonio » 28 nov. 2003, 18:25

Arf....

C'est l'occasion ou jamais :lol:

Merci pour l'idée, je vais regarder ça.

olab
Varan
Messages : 1254
Enregistré le : 30 juil. 2003, 20:20
Localisation : Niort
Contact :

Message par olab » 28 nov. 2003, 23:25

Trouvé :
http://lxr.mozilla.org/seamonkey/source ... nd.cpp#199

Et ça utilise SND_ASYNC donc c'est bien désynchronisé (ce qui ne m'étonne pas). Le problème est peut être ailleurs

Benoit
Administrateur
Messages : 4894
Enregistré le : 19 juil. 2003, 10:59
Localisation : Bruxelles, Belgique
Contact :

Message par Benoit » 29 nov. 2003, 00:42

Suis pas tout à fait d'accord, le monsieur parle de Knoppix, je pense que c'est la version GTK2
http://lxr.mozilla.org/seamonkey/source ... nd.cpp#281

Si je lis bien ça heu... crée un fichier temporaire avec le son et puis ça le joue mais je ne vois nulle part que c'est asynchrone (les NSMachinStreamLoader c'est au-delà de ce que je peux comprendre).

Claude
Gecko
Messages : 67
Enregistré le : 25 nov. 2003, 08:52
Localisation : Avignon en Provence

Message par Claude » 29 nov. 2003, 08:46

Bonjour à tous
C'est "mister newbie" qui s'imisce dans votre fil pour vous dire que j'utilise cette fonction depuis longtemps (NS 7.02 puis Moz 1.5) et que chez moi ça fontionne parfaitement.
Je ne suis pas du tous programmeur mais la description de l'incident me fait plutot penser à un manque de ressources système. Le fichier n'est il pas trop gros ? Ou dans un format "exotique" ?
En tout cas en wav ça fontionne très bien.
P.S. je suis sous W98
Espérant avoir pu aider malgré mon inexpérience
Cordialement
Claude
--- Mieux vaut allumer une chandelle que maudire l'obscurité ----

Mozilla 1.5 ; Dreamweaver 2.0 ; WebExpert 5 ; Micrografix Picture Publisher 8
Sous XP avec AthlonXP 3000

olab
Varan
Messages : 1254
Enregistré le : 30 juil. 2003, 20:20
Localisation : Niort
Contact :

Message par olab » 29 nov. 2003, 11:22

Benoit a écrit :Suis pas tout à fait d'accord, le monsieur parle de Knoppix, je pense que c'est la version GTK2
http://lxr.mozilla.org/seamonkey/source ... nd.cpp#281

Si je lis bien ça heu... crée un fichier temporaire avec le son et puis ça le joue mais je ne vois nulle part que c'est asynchrone (les NSMachinStreamLoader c'est au-delà de ce que je peux comprendre).
Oui pardon j'avais pas fait gaffe au "Knoppix", et en effet nul par n'est fai mention d'un asynchrone ou pas dans le code source, je sais pas comment fonctionne linux sur ce point là...

TEPEDEV
Salamandre
Messages : 28
Enregistré le : 09 oct. 2003, 10:25

Message par TEPEDEV » 06 déc. 2003, 22:58

Bonjour à tous!

Je suis sous la version 1.3, et j'ai beau choisir un son wav perso pour prévenir d'un nouveau message, je me retrouve toujours avec le son "ding" standard!

que faire?

Bon vent à tous!

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités