Installation Ubuntu

Quand tout est (trop ?) bien organisé, il y a besoin d'une ouverture. Ici on parle de tout, mais pas de n'importe quoi, vous êtes prévenus.
Avatar du membre
Mori
Animal mythique
Messages : 13310
Enregistré le : 30 avr. 2004, 19:17

Message par Mori » 25 mai 2006, 18:29

salut,

dites ... vous arrêtez de me faire dire n'importe quoi ... :P
"instable" se rapportait aux trois paquets pour mon eagle (gcc, cpp_gcc, gcc_base) pris dans la branche unstable de debian (ça marche bien comme ça, non ? unstable, testing, release / stable) ... je n'ai jamais parlé de ubu, qui serait instable (au sens de bugguée) ... je ne suis pas du genre à conseiller des versions bugguées, non ?

ensuite, je compare ce qui est comparable : deux stables (release) ... et jusqu'à preuve du contraire dapper (dont je n'ai pas parlé sauf pour ueagleatm, en mettant sur le même plan que fedora et sauf pour ipv6) jusqu'au 2/06/06 est en testing (ou équivalent) ... donc, je parlais de breezy, ok ? mais je n'ai jamais dit que dapper ne fonctionnait pas.

donc sous breezy, effectivement, pour avoir ooo2.0.2, on a conseillé sur le forum (et documentation ?) de mettre un http qui n'avait rien à voir avec universe, multiverse ... et pour ff 1.5, on peut avoir des conseils allant de dpkg -i ff.deb à installation de la packagisation par Asher d'une version de dapper testing pour breezy stable ... si ce n'est pas du bricolo, qu'est-ce que c'est ?

mais en aucun cas, je n'ai dénigré, j'ai dit simplement : fantaisie de simon le bricolo ... on parlait bien de fantaisie ?

ben, mon vieux ... pfff

heu ... deot pour ta question de rpm : dans ton lien, au dessus de la mention des packages debian, en gras, c'est eux les rpm.
quant à conseiller la distro que j'utilise, je suis effectivement particulièrement violent : http://www.geckozone.org/forum/viewtopi ... 923#272923

quant à ff 1.5.0.3 sous fc5, il est dans core (stable) et pas testing ni devel ... je n'utilise que du stable sous fc5.

vous êtes nerveux les mecs ; faut vous détendre. :)
Linux openSUSE Leap 15.2 (Gnome)

Ben.d2
Iguane
Messages : 597
Enregistré le : 03 mai 2004, 13:12

Message par Ben.d2 » 25 mai 2006, 19:21

J'avais bien compris. Et je persiste ! :wink:

Firefox 1.5 est dans Dapper.
Firefox 1.0 est dans Breezy.

Si on regarde chez gentoo (ce sont les deux distributions que j'ai installées sur mes PC) :
Firefox 1.5 est en ~x86 (instable).
Firefox 1.0 est en x86 (stable).

Si Firefox 1.5 est instable sur ces deux systèmes c'est qu'il y a une raison. Les développeurs d'Ubuntu et de Gentoo estiment que Firefox 1.5 n'est pas prêt pour être intégré à la version stable de leur système. Il peut y avoir plusieurs raisons à cela : bug, dépend d'un logiciel instable, etc.

Tu te plains que pour avoir Firefox 1.5 il faut bricoler. Mais c'est normal. Firefox 1.5 fait partie de la branche instable d'Ubuntu, il n'y a aucune raison qu'on puisse l'installer facilement si on est dans la branche stable.

bisdi
Lézard vert
Messages : 126
Enregistré le : 15 mars 2006, 22:31

Message par bisdi » 25 mai 2006, 20:05

Hé ben, je constate que les Ubuntiste sont de vraie feignasse ! :lol:

Je sais pas si c'est le cas pour les distrib linux, mais en tout cas, le fait que ca soit en "unstable" n'est pas anondin : disons qu'il mettent l'appelation "stable" quand la distribution est "stable". Quand elle ne l'ai pas, les packages sont "unstable". Ca na rien avoir avec le fait que le programme ne soit pas stable ou pas, c'est juste histoire de regrouper distributions avec packages sous la même appelations : stable
Opera/9.01 (X11; Linux i386; U; fr)

Ben.d2
Iguane
Messages : 597
Enregistré le : 03 mai 2004, 13:12

Message par Ben.d2 » 25 mai 2006, 20:31

Non, je pense que tu te trompes. Même si pour Ubuntu il y a un peu de ça. Mais une nouvelle version d'un logiciel peut très bien être ajoutée à Breezy, ça ne poserait aucun problème.

Ensuite, je suis pas une feignasse (j'ai installé ma gentoo à la console et configuré mon noyau... si je suis une feignasse, je suppose que pour ne plus l'être il me faudra modifier les codes sources des programmes que j'utilise :wink: ). Ni un ubuntiste, je préfère largement Gentoo :wink:
D'ailleurs je ne vois pas le rapport avec la fainéantise. Il s'agit de ma compréhension des gestionnaires de paquets :?

Mais en y réfléchissant, ce que je dis est surtout vrai pour Gentoo. Mais ça reste vrai pour Ubuntu, même si leur système de grosse màj tous les 6 mois les amène à marquer des applications en "instable" alors qu'il n'y a pas de raison.

bisdi
Lézard vert
Messages : 126
Enregistré le : 15 mars 2006, 22:31

Message par bisdi » 25 mai 2006, 21:25

Ben.d2 a écrit :Non, je pense que tu te trompes. Même si pour Ubuntu il y a un peu de ça. Mais une nouvelle version d'un logiciel peut très bien être ajoutée à Breezy, ça ne poserait aucun problème.
En version stable ou instable ?

Mais c'est vrai que tu soulèves une belle question : ca vaut dire quoi "stable" ou "instable" ?

J'suis pas sur que ca veut dire que le programme en question sois instable ( dû moins ca m'étonnerait que ca soit la seule raison ) tout simplement car je vois mal les développeurs ( mainteneur ) trifouiller dans le code de Firefox juste histoire de le faire :roll: ( surtout qu'il y a des miliers de packages, et qu'il n'y a donc aucun intéret :? )
Peut être que dans certain cas, le mot "'unstable" et "stable" signifie autre chose :?:

Je n'ai pas dis que les Gentooiste étaient des feignasses ( d'ailleurs ca serai bête de le dire, surtout que Gentoo est basé sur le principe de FreeBSD ;) ) mais que les Ubuntiste l'étaient. Ne suffit - il pas de télécharger Firefox à partir des miroirs officiels et de l'installer ? Sur ce cas, ce n'est pas de la compréhension mais bien de la fainéantise ;)
Opera/9.01 (X11; Linux i386; U; fr)

epsy
Varan
Messages : 1024
Enregistré le : 21 déc. 2005, 19:58

Message par epsy » 25 mai 2006, 21:47

à mon avis ils n'ajoutent pas firefox 1.5 dans leur dépot car cela risquerai de rendre le dépot instable...

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
҈ - config- http://fr.enlightenment.org - wikipedia mon amiiii! - JID: epsy arobase :) jaim.at

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 25 mai 2006, 22:04

Est-ce que "stable" ne serait pas à prendre ici dans son sens "continuité" ?

Pour moi, lors du passage de Firefox 1.0 à 1.5, il y a tout un tas de changements qui ne sont pas nécéssairements anodins. Au niveau des extensions par exemple (mais pas seulement).

Étant donné que la mise à jour se ferait quasi automatiquement (on a juste à cliquer sur une infobulle puis "installer"), il ne serait pas acceptable pour les utilisateurs qu'une extension, un thème ou autre soient désactivés. Car à ce moment là il y aurait une modification plus radicale que "juste" une mise à jour de programme, il pourrait y avoir besoin de revoir pas mal de choses dans certaines conditions pour ne pas perdre de fonctionnalité.

Donc voilà, pour moi, stable, ça veut dire "qu'on peut continuer d'utiliser de la même manière" :wink:

PS : ce serait encore plus vrai au niveau des serveurs. L'exemple flagrant c'est apache : est-ce qu'il viendrait à l'idée de passer "automatiquement" de la 1.3 à la 2.0 ? Non ! Il y a beaucoup trop de choses "autres" qui en dépendent, même si apache 2 est très stable, ça ne peut pas faire l'objet d'une mise à jour "mineure". :wink: Pour Firefox 1.0->1.5 c'est le même type de mise à jour majeure.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités