Konqueror sous Windows

Quand tout est (trop ?) bien organisé, il y a besoin d'une ouverture. Ici on parle de tout, mais pas de n'importe quoi, vous êtes prévenus.
calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Konqueror sous Windows

Message par calimo » 06 mai 2006, 22:43

Ça y est, j'ai enfin réussi à installer KDE sous Windows ! :)

Et voilà le résultat.

Bon, comme vous le voyez, il y a encore une certaine marge de progression :lol: Mais je suis sur la bonne route.

Il faut vraiment que je trouve un ordi avec un lecteur CD pour m'installer un Linux en dual boot :roll:

HP
Tyrannosaurus Rex
Messages : 2196
Enregistré le : 21 oct. 2004, 10:25

Message par HP » 07 mai 2006, 00:23

ça progresse :shock:

dommage pas de KHTML sous Win quand même :(

“La médiocrité obtiendra immanquablement la préséance en se travestissant des oripeaux de la bienséance.”

arno.
Varan
Messages : 1347
Enregistré le : 19 août 2004, 12:26

Re: Konqueror sous Windows

Message par arno. » 07 mai 2006, 00:28

calimo a écrit :
Il faut vraiment que je trouve un ordi avec un lecteur CD pour m'installer un Linux en dual boot :roll:
Si ce n'est que ça le probléme, je sais qu'on peut installer mandrake ou debian à partir de quelques disquettes, tout le reste par le réseau, j'imagine que d'autres distributions peuvent aussi. Ce n'est pas très compliqué.

Jim
Tyrannosaurus Rex
Messages : 3228
Enregistré le : 20 juil. 2005, 14:34

Message par Jim » 07 mai 2006, 09:21

Salut,

Sinon, tu te trouve un ordinateurqui à un port USB, et tu installes Linux en dual boot :mrgreen:

Et je suis sûr, que tu peux même installer à partir d'une disquette, ceci avec moins de recherche que celle que tu as fait pour installer Konqueror sur Windows... :wink:

Benoit
Administrateur
Messages : 4894
Enregistré le : 19 juil. 2003, 10:59

Message par Benoit » 07 mai 2006, 09:33

Ou tu achètes une très grosse clé USB (plus de 700 Mo) et tu te fais une Live Clé USB :lol:

PS: Ton résultat c'est en natif ou en utilisant le serveur X de cygwin ? Ou un autre comme X-Win32 ?

PS2: C'est vraiment toujours aussi moche KDE... on dirait un Firefox avec le thème Noia eXtreme.
♫ Li tens s'en veit, je n'ai riens fais ;
Li tens revient, je ne fais riens. ♪

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 07 mai 2006, 10:17

arno. a écrit :Si ce n'est que ça le probléme, je sais qu'on peut installer mandrake ou debian à partir de quelques disquettes, tout le reste par le réseau, j'imagine que d'autres distributions peuvent aussi. Ce n'est pas très compliqué.
Jim a écrit :Salut,

Sinon, tu te trouve un ordinateurqui à un port USB, et tu installes Linux en dual boot :mrgreen:

Et je suis sûr, que tu peux même installer à partir d'une disquette, ceci avec moins de recherche que celle que tu as fait pour installer Konqueror sur Windows... :wink:
Ce que je voulais dire, c'est qu'il faut que je me retrouve un nouvel ordi :lol:
Benoit a écrit :PS: Ton résultat c'est en natif ou en utilisant le serveur X de cygwin ? Ou un autre comme X-Win32 ?
Non, c'est du cygwin, c'est lent et compliqué à mettre en place (je veux dire, à démarrer, on peut pas "juste" cliquer sur konqueror.exe, il faut démarrer cygwin, lancer X, et tout et tout).
Benoit a écrit :PS2: C'est vraiment toujours aussi moche KDE... on dirait un Firefox avec le thème Noia eXtreme.
Je ne te le fais pas dire :lol:
Au moins ils ont le mérite d'avoir fait un navigateur :wink:

PS : j'ai aussi réussi à démarrer le bureau KDE complet… avec exactement le même problème :? (et quelle lenteur !)

PPS : pour ceux qui seraient intéressés à faire mieux que moi niveau police, la marche à suivre détaillée est là : http://webdev.cegit.de/snapshots/kde-cygwin/kde/kde3.4/ (visiblement à part ce problème de police elle fonctionne).

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 06 août 2007, 15:31

Bon bon, ça progresse, ça progresse :lol:

Image
(si si je vous promets, c'est sous windows, la preuve ! :lol: le fond gris c'est le fond X qui se remets quand on déplace ou redimensionne une fenêtre, on voit la barre des tâches caractéristique de windows).

On a droit aux décorations de fenêtres de KWin, on peut même démarrer le bureau complet (mais c'est pas terrible, le menu se présente sous forme d'une fenêtre qui revient en place si on la déplace ou la redimensionne...). (J'ai pas réussi à faire la capture d'écran, il va falloir que je retente). On peut virtuellement démarrer n'importe quelle application KDE : Kate, etc !

Bon, c'est pas du natif, le script de démarrage pour lancer cygwin puis XWin puis KWin puis Konqueror est un peu tordu, mais on y arrive :lol: (facilement en se servant des scripts existants de cygwin)

Et puis quelle lenteur ! :shock: :?

Mais que de progrès depuis 2004 ! :roll:

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

PS : oui, c'est du déterrage de sujet, et alors ? J'assume :lol:

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 06 août 2007, 15:55

Bon, j'ai réussi à faire quelques captures d'écran !

Donc voici le bureau KDE au démarrage : un peu le bordel :lol:
Image
Remarquez que Konqueror a les décorations de fenêtre kwin... en fait il y a un doublon, une couche "windows-classic" et une "kwin" et si on clique sur le "x" du windows classic, on arrive avec les applis qui ont les décorations windows "normales"... :roll: et avec le nom correct dans la barre des tâches de Windows ! :lol:

Après (ou juste avant je sais plus), un joli message d'erreur :
Image
N'empêche j'ai eu droit à un joli son quand-même !

Au bout d'un moment le menu redescend et va se glisser sous la barre des tâches de windows. Heureusement que cette dernière est plus petite pour piger l'erreur. Du coup si on la masque automatiquement, on arrive à avoir quelque chose comme ça :
Image

C'est marrant, mais ça va un moment, donc on quitte :
Image
Sauf que ça fonctionne pas bien (ou bien j'ai pas assez attendu ?). Le menu (klipper) reste ouvert, il y a des fenêtre sh.exe vides qui s'ouvrent, le serveur X finit par crasher... mais bon, Konqueror est maintenant accessible aux pauvres windowsiens :)

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6


PS : on peut aussi installer gnome et xfce, mais je vous dit pas à quel point ça ne fonctionne pas... en fait, un moment ça lance un petit bout du panel, puis plus tard plus rien... :?

PPS : Ah oui, j'oubliais, évidemment la méthode d'installation a encore changé, il ne faut plus regarder kde-windows mais Cygwin Ports :wink:

petitjean
Lézard à collerette
Messages : 228
Enregistré le : 23 juin 2004, 18:42

Message par petitjean » 10 août 2007, 20:21

Bonsoir
Qui a dit que KDE c'est moche!!! :D

Image

Voili voilou

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 10 août 2007, 20:44

petitjean a écrit :Qui a dit que KDE c'est moche!!! :D
Moi ? :lol:
Bon, je pense que ce n'est pas une capture sous Windows, et puis ça n'a plus grand chose de KDE, mais je dois avouer que ça semble plutôt agréable :)

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20061201 Firedragon Firefox/2.0.0.6 (Ubuntu-feisty)

petitjean
Lézard à collerette
Messages : 228
Enregistré le : 23 juin 2004, 18:42

Message par petitjean » 10 août 2007, 20:53

Allez un tit dernier et je vais coucher les enfants:
Image



Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 10 août 2007, 20:55

Beurk, ça éblouit :?
Je déteste les fonds d'écran "coucher de soleil" qui font mal aux yeux :lol:

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20061201 Firefox Firefox/2.0.0.6 (Ubuntu-feisty)

Yoko
Varan
Messages : 1203
Enregistré le : 13 nov. 2005, 11:47

Message par Yoko » 10 août 2007, 21:34

petitjean a écrit :Bonsoir
Qui a dit que KDE c'est moche!!! :D

Image

Voili voilou
Je peux faire la même chose de mon Gnome.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.8.1.6) Gecko/20070723 Iceweasel/2.0.0.6 (Debian-2.0.0.6-0etch1)
Membre auto-bannis du forum

Benoit
Administrateur
Messages : 4894
Enregistré le : 19 juil. 2003, 10:59

Message par Benoit » 10 août 2007, 22:54

calimo a écrit :
petitjean a écrit :Qui a dit que KDE c'est moche!!! :D
Moi ? :lol:
Non, moi !

Et je persiste :mrgreen:
♫ Li tens s'en veit, je n'ai riens fais ;
Li tens revient, je ne fais riens. ♪

nico@nc
Animal mythique
Messages : 8038
Enregistré le : 21 août 2005, 08:04

Message par nico@nc » 10 août 2007, 23:00

Benoit a écrit :
calimo a écrit :
petitjean a écrit :Qui a dit que KDE c'est moche!!! :D
Moi ? :lol:
Non, moi !

Et je persiste :mrgreen:
S'il y a un truc que je n'aime pas chez KDE, c'est l'horloge "lcd" par défaut.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Nicolas
☛ Problème [résolu] ? Modifiez votre premier message pour l'indiquer.
Pas de support par message privé, postez sur le forum, merci.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité