« Ubuntu », ce mot d'humanité

Quand tout est (trop ?) bien organisé, il y a besoin d'une ouverture. Ici on parle de tout, mais pas de n'importe quoi, vous êtes prévenus.
epsy
Varan
Messages : 1024
Enregistré le : 21 déc. 2005, 19:58

Message par epsy » 31 août 2006, 11:30

t'aurais pas désactivé ACPi ? j'ai eu je me rappelle avoir eu des problemes avec dhcp quand APM était activé...
҈ - config- http://fr.enlightenment.org - wikipedia mon amiiii! - JID: epsy arobase :) jaim.at

Jim
Tyrannosaurus Rex
Messages : 3228
Enregistré le : 20 juil. 2005, 14:34

Message par Jim » 31 août 2006, 11:56

La je suis surpris par ta question Epsy...

En ce qui concerne ACPI et APM, j'ai depuis le début compris que c'était l'un OU l'autre... Mais pas les deux.
Image

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 31 août 2006, 13:15

Mori a écrit :et avec fedora, tu as aussi ce problème ?
Fedora, c'est au boulot, c'est là que j'ai pas le mot de passe root pour mettre le dictionnaire :lol:

Pour ACPi (ou APM) je ne crois pas avoir fait autre chose qu'installer KDE, mais il n'est pas exclu que ce soit invasif et que ça ait désactivé d'autres choses :?

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

bisdi
Lézard vert
Messages : 126
Enregistré le : 15 mars 2006, 22:31

Message par bisdi » 31 août 2006, 19:55

calimo a écrit :
calimo a écrit :Ce qui donnerait alors

Code : Tout sélectionner

/dev/sda1       /media/sda1     vfat    defaults,user,noauto,utf8,umask=007,gid=46 0       1 
J'ai bon :?:
Arf, depuis hier, ça re-coince :?
Je sens que ça va encore se finir en réinstallation :roll: (le fichier n'a pas changé, par contre j'ai probablement fait une c*** en installant KDE :? ) :(

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.5) Gecko/20060731 Firesalamandre/dapper-security Firefox/1.5.0.5
Je peux me tromper mais il me semble que l'option "default" place par défaut le périphérique en montage automatique ....

Je viens de vérifier, selon le man :
defaults
Utilisation des options par défaut : rw,
suid, dev, exec, auto, nouser, et async.
maintenant, est-ce que le fait d'avoir mis après l'option "noauto" fonctionne, bonne question ... ( et j'ai la flemme de tout lire )

Essaie donc d'enlever "default"

De plus, il me semble également que pour les périphériques amovibles : il faut mettre deux zéros à la fin... et pas zéro et un.

Et comme le dit très bien Jim, soit c'est l'APM oit l'ACPI... et je suppose que les linuxiens eux aussi règlent ca dans le noyau.
Opera/9.01 (X11; Linux i386; U; fr)

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 31 août 2006, 20:50

Eh ben aujourd'hui ça a démarré. J'essaierai sans clé demain :wink:

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.5) Gecko/20060731 Firefox/dapper-security Firefox/1.5.0.5

epsy
Varan
Messages : 1024
Enregistré le : 21 déc. 2005, 19:58

Message par epsy » 31 août 2006, 21:32

c'est vrai qu'avec cette config tu as une machine qui ne démarre pas chare 30e fois :lol:
҈ - config- http://fr.enlightenment.org - wikipedia mon amiiii! - JID: epsy arobase :) jaim.at

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 31 août 2006, 21:42

Disons que c'est assez fréquent en effet. Mais là pendant 2 jours : rien ! :?
Au passage, elle ne démarre pas si elle ne trouve pas le réseau. C'est une vraie catastrophe :roll:

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.5) Gecko/20060731 Firerenard/dapper-security Firefox/1.5.0.5

MehdiB
Arias
Messages : 3
Enregistré le : 18 sept. 2006, 12:10

Message par MehdiB » 22 sept. 2006, 23:26

calimo a écrit :Hop, je déterre ce vieux sujet, car j'ai trouvé ça : http://www.andesi.org/index.php?node=108

Je viens (enfin !) de réussir à compiler Firefox :D (même si c'est pas les sources officielles :lol: )

Salut est ce que quelqu'un peut me dire, ou m'indiquer un bon lien, comment je peux compiler tt seul Firefox 1.5 sur Ubuntu? Je bloke!!
En fait je ve rajouter à Firefox des composants XPCOM permettant d'interagir avec un annuaire LDAP.. Je dois donc recompiler? il n'y a pas une autre solution?

Merci d'avance

Message envoyé avec : Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
MehdiB

Philippe-Pierre
Lézard à collerette
Messages : 475
Enregistré le : 29 août 2006, 19:58

Message par Philippe-Pierre » 23 sept. 2006, 09:00

La documentation officielle :
http://developer.mozilla.org/en/docs/Bu ... umentation

MehdiB, qu'appelles-tu au juste "rajouter à Firefox des composants XPCOM" ?

Sinon, quels problèmes rencontres-tu en compilant FX ?

Pour le reste, compiler Firefox sous n'importe quelle distribution Linux c'est la même chose, pourvu que tu aies les programmes qui vont bien.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.0.7) Gecko/20060916 SeaMonkey/1.0.5
Cordialement,

Philippe
----
* Dedicated to software which sucks less ... http://suckless.org/

calimo
Animal mythique
Messages : 14118
Enregistré le : 26 déc. 2003, 11:51

Message par calimo » 23 sept. 2006, 10:01

Philippe-Pierre a écrit :pourvu que tu aies les programmes qui vont bien.
Je crois justement que c'est le problème sous Ubuntu :?

Vu que les sources des dépôts Ubuntu compilent, je pense avoir tout, mais les sources officielles ne compilent quand-même pas :?

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.7) Gecko/20060921 Firefox/dapper-security Firefox/1.5.0.7

Philippe-Pierre
Lézard à collerette
Messages : 475
Enregistré le : 29 août 2006, 19:58

Message par Philippe-Pierre » 23 sept. 2006, 10:28

Bien sûr, quand je dis "toutes les distributions", je généralise bien au delà de ce que je peux dire de façon certaine, c'est juste que ça me paraît une généralisation raisonnable. La réalité est que je n'ai jamais compilé Fx ou SeaMonkey que sous Mandriva et Debian testing...
Mais enfin on peut rencontrer tellement d'embûches en compilant ces gros programmes et de tant d'origine différentes, que c'est très délicat (en tout cas pour moi) d'épauler quelqu'un là-dessus. Il faudrait être programmeur, et je suis juste empirique. Si je vois une erreur de compilation que je connais, ça va, sinon...
M'enfin c'est comme beaucoup de choses : plus on l'a fait, plus ça roule, et plus les nouvelles erreurs (il y en a toujours) sont identifiables distinctement.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.0.7) Gecko/20060916 SeaMonkey/1.0.5
Cordialement,

Philippe
----
* Dedicated to software which sucks less ... http://suckless.org/

Philippe-Pierre
Lézard à collerette
Messages : 475
Enregistré le : 29 août 2006, 19:58

Message par Philippe-Pierre » 23 sept. 2006, 10:34

calimo a écrit :Vu que les sources des dépôts Ubuntu compilent, je pense avoir tout, mais les sources officielles ne compilent quand-même pas :?
Bah, il te reste à faire un monumental vimdiff sur les 2 sources :-).

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.0.7) Gecko/20060916 SeaMonkey/1.0.5
Cordialement,

Philippe
----
* Dedicated to software which sucks less ... http://suckless.org/

MehdiB
Arias
Messages : 3
Enregistré le : 18 sept. 2006, 12:10

Message par MehdiB » 24 sept. 2006, 00:08

Philippe-Pierre a écrit :
MehdiB, qu'appelles-tu au juste "rajouter à Firefox des composants XPCOM" ?

Sinon, quels problèmes rencontres-tu en compilant FX ?

Pour le reste, compiler Firefox sous n'importe quelle distribution Linux c'est la même chose, pourvu que tu aies les programmes qui vont bien.

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.0.7) Gecko/20060916 SeaMonkey/1.0.5
Par rajouter à Firefox des composants XPCOm je ve dire exactement que lorsque j'utilise Component Viewer, ca m'affiche une liste de composants de la forme "@mozilla.org/..." ainsi que les interfaces qu'ils implémentent (de la forme nsI...) et moi je veux rajouter les composants @mozilla.org.network/ldap-connection;1 et @mozilla.org.network/ldap-url;1 qui implémentent respectivement les interfaces nsILDAPConnection et nsILDAPURL.
Voila! Et malheureusement ca fait quelques jours que je blok la dessus....
MehdiB

Philippe-Pierre
Lézard à collerette
Messages : 475
Enregistré le : 29 août 2006, 19:58

Message par Philippe-Pierre » 24 sept. 2006, 10:04

Quel outil utilises-tu pour tes modifs ? Et qu'est-ce que ça te dit quand tu tentes de compiler ?

Message envoyé avec : Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.8.0.7) Gecko/20060916 SeaMonkey/1.0.5
Cordialement,

Philippe
----
* Dedicated to software which sucks less ... http://suckless.org/

Nicosmos
Iguane
Messages : 633
Enregistré le : 20 août 2005, 14:17

Message par Nicosmos » 24 sept. 2006, 10:51

Dites, on en est où avec Edgy ? Autant, Dapper, on en parlait beaucoup quelques mois avants, autant la 6.10 c'est dans un mois, et personne n'en parle.

L'article de Wikipédia n'est pas très complet et le wiki d'Ubuntu est en panne ...

:?

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité